解决Kali Linux更新报错问题

1、今天在 kail 下准备更新的时候执行命令
apt-get update && apt-get upgrade && apt-get dist-upgrade
却发现报错了,尴尬

正在读取软件包列表... 完成   
E: 无法找到获取软件包的渠道 /usr/lib/apt/methods/https 所需的驱动程序。
N: 请检查是否安装了 apt-transport-https 软件包
E: 无法下载 https://mirrors.ustc.edu.cn/kali/dists/kali-rolling/InRelease  
E: 部分索引文件下载失败。如果忽略它们,那将转而使用旧的索引文件。

2、这个问题有两个原因:
没有安装 apt-transport-https 软件包和 Kali Linux 由于太长时间未更新,密钥过期了,需要更新密钥

3、先安装 apt-transport-https 软件包
apt-get install apt-transport-https

4、更新秘钥
wget -q -O - https://archive.kali.org/archive-key.asc | apt-key add

5、重新再一次进行升级
apt-get update && apt-get upgrade && apt-get dist-upgrade

发表评论

电子邮件地址不会被公开。必填项已用 * 标注